Project

General

Profile

Feature #305

Plugin crashes on RM 1.0.1 (error 500)

Added by Paul L about 11 years ago. Updated almost 11 years ago.

Status:
Rejected
Priority:
High
Category:
General
Target version:
Start date:
2010-08-26
Due date:
2010-12-10
% Done:

100%

Estimated time:
Milestones:

Description

Clicking Roadmap produces the following error:


ActionView::TemplateError (undefined method `rest_hours' for #<Issue:0x2d6fe730>) on line #21 of vendor/plugins/advanced_roadmap/app/views/projects/roadmap.rhtml:
18:     @versions.each do |version|
19:       estimated_hours += version.estimated_hours
20:       spent_hours += version.spent_hours
21:       rest_hours += version.rest_hours
22:       completed_pourcent += version.spent_hours
23:       closed_pourcent += version.closed_spent_hours
24:     end

    vendor/plugins/advanced_roadmap/app/views/projects/roadmap.rhtml:21:in `_run_rhtml_vendor47plugins47advanced_roadmap47app47views47projects47roadmap46rhtml'
    vendor/plugins/advanced_roadmap/app/views/projects/roadmap.rhtml:18:in `each'
    vendor/plugins/advanced_roadmap/app/views/projects/roadmap.rhtml:18:in `_run_rhtml_vendor47plugins47advanced_roadmap47app47views47projects47roadmap46rhtml'
    passenger (2.2.15) lib/phusion_passenger/rack/request_handler.rb:92:in `process_request'
    passenger (2.2.15) lib/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:441:in `start_request_handler'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:381:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/utils.rb:252:in `safe_fork'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:377:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `main_loop'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:163:in `start'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:222:in `start'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:253:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:247:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:246:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:145:in `spawn_application'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:278:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `main_loop'

Rendering /usr/local/www/redmine/public/500.html (500 Internal Server Error)

Clicking an issue generates the same error.

#1

Updated by Paul L about 11 years ago

Do you know what the issue is?
Thank you.

#2

Updated by Slava Karg almost 11 years ago

which version of plugin do you use?

#3

Updated by Paul L almost 11 years ago

Slava Karg escribió:

which version of plugin do you use?

0.1.0

#4

Updated by Paul L almost 11 years ago

Any news?

#5

Updated by Emilio González Montaña almost 11 years ago

  • Due date set to 2010-12-10
  • Category set to General
  • Status changed from New to Rejected
  • % Done changed from 0 to 100

I don't reproduce this problem into the new version version:0.2.0.

Please reopen if the problem persists, and attach the logs...

#6

Updated by Emilio González Montaña almost 11 years ago

  • Target version set to Advanced roadmap 0.2.0
#7

Updated by Emilio González Montaña almost 11 years ago

  • Assignee set to Emilio González Montaña
#8

Updated by Paul L almost 11 years ago

Still doesn't work, although the error is different now (below). Using Redmine 1.0.4 with PostgreSQL.


ActionView::TemplateError (undefined method `rest_hours' for #<Issue:0x2d9d42e8>) on line #17 of app/views/versions/_overview.rhtml:
14: </ul>
15:
16: <% if version.fixed_issues.count > 0 %>
17:     <%= progress_bar([version.closed_pourcent, version.completed_pourcent], :width => '40em', :legend => ('%0.0f%' % version.completed_pourcent)) %>
18:     <p class="progress-info">
19:         <%= link_to_if(version.closed_issues_count > 0, l(:label_x_closed_issues_abbr, :count => version.closed_issues_count), :controller => 'issues', :action => 'index', :project_id => version.project, :status_id => 'c', :fixed_version_id => version, :set_filter => 1) %>
20:         (<%= '%0.0f' % (version.closed_issues_count.to_f / version.fixed_issues.count * 100) %>%)

    app/views/versions/_overview.rhtml:17:in `_run_rhtml_app47views47versions47_overview46rhtml_locals_object_overview_version'
    vendor/plugins/advanced_roadmap.0.2.0/app/views/versions/_info.html.erb:1
    vendor/plugins/advanced_roadmap.0.2.0/app/views/versions/index.html.erb:9
    vendor/plugins/advanced_roadmap.0.2.0/app/views/versions/index.html.erb:7:in `each'
    vendor/plugins/advanced_roadmap.0.2.0/app/views/versions/index.html.erb:7
    passenger (2.2.15) lib/phusion_passenger/rack/request_handler.rb:92:in `process_request'
    passenger (2.2.15) lib/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:441:in `start_request_handler'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:381:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/utils.rb:252:in `safe_fork'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:377:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `main_loop'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:163:in `start'
    passenger (2.2.15) lib/phusion_passenger/railz/application_spawner.rb:222:in `start'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:253:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:247:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
    passenger (2.2.15) lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:246:in `spawn_rails_application'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:145:in `spawn_application'
    passenger (2.2.15) lib/phusion_passenger/spawn_manager.rb:278:in `handle_spawn_application'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:352:in `main_loop'
    passenger (2.2.15) lib/phusion_passenger/abstract_server.rb:196:in `start_synchronously'

Rendering /usr/local/www/redmine/public/500.html (500 Internal Server Error)

Also available in: Atom PDF