Project

General

Profile

Error #313

Roadmap does not show %done

Added by Arn Vollebregt about 11 years ago. Updated almost 11 years ago.

Status:
Rejected
Priority:
Normal
Category:
Roadmap
Target version:
Start date:
2010-09-08
Due date:
2010-12-10
% Done:

0%

Estimated time:
Source:
Detected on version:
Redmine version:
Milestones:

Description

Spent hours are shown instead:

roadmap.rhtml line12/13

completed_pourcent += version.spent_hours
closed_pourcent += version.closed_spent_hours

_issues.rhtml line 41

"         <td align=\"center\"><font color=\"#{color}\">#{begin_strike}#{(("%.0f" % issue.done_ratio) + "%") if issue.estimated_hours}#{end_strike}</font></td>\n" +


Files

roadmap_1.png (74.7 KB) roadmap_1.png Arn Vollebregt, 2010-09-08 16:19
issue_1.png (78.8 KB) issue_1.png Arn Vollebregt, 2010-09-08 16:19
roadmap_2.png (69.9 KB) roadmap_2.png Arn Vollebregt, 2010-09-08 16:19
issue_2.png (77.5 KB) issue_2.png Arn Vollebregt, 2010-09-08 16:19
#1

Updated by Emilio González Montaña about 11 years ago

Is the problem in the last version 0.1.0? I don't understand the problem, in the Roadmap of this project the isses show the done % perfectly.
If you have a public Redmine instance, please link it here with the Roadmap/Version/Milestone view with the problem.

#2

Updated by Arn Vollebregt about 11 years ago

Emilio González Montaña escribió:

Is the problem in the last version 0.1.0?

I am using advanced_roadmap.0.1.0.tar.gz with Redmine 1.0.1.stable (MySQL)

I don't understand the problem, in the Roadmap of this project the isses show the done % perfectly.
If you have a public Redmine instance, please link it here with the Roadmap/Version/Milestone view with the problem.

I dont have a public instance, but I have attached screenshots for you.

This roadmap view does not show a %done:

while the issue is in fact 30% done:

and when I change the estimated time in the issue:

a %done is shown for the version:

However, the %done still is not show for the overall project?

#3

Updated by Emilio González Montaña almost 11 years ago

The problem is that you haven't logged time for the issue, so the total can't be calculated...

#4

Updated by Emilio González Montaña almost 11 years ago

  • Due date set to 2010-12-10
  • Status changed from New to Rejected
  • % Done changed from 50 to 0
#5

Updated by Emilio González Montaña almost 11 years ago

  • Target version set to Advanced roadmap 0.2.0

Also available in: Atom PDF