Project

General

Profile

Error #352

Plugin incompatible from Redmine v1.0.0

Added by Robert Gründler almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
General
Target version:
Start date:
2010-12-03
Due date:
2010-12-08
% Done:

100%

Estimated time:
Source:
Detected on version:
Redmine version:
Milestones:

Description

The current version (0.1.0) is not compatible with trunk of redmine, see discussion on redmine.org

Are there any plans to update this plugin to work with future versions of redmine?


Files

advanced_roadmap_redmine_1.0.3.diff (10.3 KB) advanced_roadmap_redmine_1.0.3.diff Christoph Plank, 2010-11-05 12:08
#1

Updated by Slava Karg almost 11 years ago

confirm. Plugin is incompatible with stable 1.0.2 RM version too :(

#2

Updated by Dave Smith almost 11 years ago

Confirmed, I am also running 1.0.2.

Receive the following message when attempting to run db migration:

sudo rake db:migrate_plugins RAILS_ENV=production
(in /var/www/redmine/redmine-1.0.2)
rake aborted!
undefined method `roadmap' for class `ProjectsController'
(See full trace by running task with --trace)

Are there any immediate plans to bring the plugin up-to-date with the latest Redmine release?

#3

Updated by Grigoriy Klimov almost 11 years ago

I am also using redmine 1.0.2, and got same error.

Waiting for fix.

#4

Updated by Christoph Plank almost 11 years ago

I also had the same problem after an upgrade. The attached patch made it work for me again. I'm using version 1.0.3.

Hope this helps someone :)

#5

Updated by Dmitry Shalashov almost 11 years ago

Christoph Plank patch worked fine for me (1.0.3 too), thanks.

copy .diff file to your vendor/plugins dir and run:
patch -p0 < advanced_roadmap_redmine_1.0.3.diff

after that you can install patch as common

#6

Updated by DArren Brakenridge almost 11 years ago

I've tried to apply this patch but when running the patch command stated above it gives me an error and says the file contains garbage data.?
I'm using version 1.0.3

#7

Updated by DArren Brakenridge almost 11 years ago

The exact error is:

root@~:/var/www/railsapp/vendor/plugins# patch -p0 < advanced_roadmap_redmine_1.0.3.diff
patch: ** Only garbage was found in the patch input.

Am i missing something?

#8

Updated by Slava Karg almost 11 years ago

I guess current directory should be (in your particular case) /var/www/railsapp

#9

Updated by Slava Karg almost 11 years ago

I take my words back after looking at the code of patch :)

It seems like your plugin "advanced_roadmap" should have name "advanced_roadmap.new"

#10

Updated by Robert Gründler almost 11 years ago

the patch works fine here too, thanks a lot!

#11

Updated by Robert Gründler almost 11 years ago

i'm not sure if it's related to the patch, but when i click on "milestones" on the sidebar of the roadmap page, i get

NoMethodError (undefined method `count' for {5=>5}:Hash):
  vendor/plugins/advanced_roadmap/app/controllers/milestones_controller.rb:20:in `show'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
  /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

#12

Updated by Robert Gründler almost 11 years ago

The plugin creates another error, when viewing an issue that has a changeset attached:

ActionView::TemplateError (undefined local variable or method `issue' for #<ActionView::Base:0x2b19374d3980>) on line #16 of app/views/issues/_history.rhtml:
13:       <% end %>
14:     </ul>
15:     <% end %>
16:     <%= render_notes(issue, journal, :reply_links => reply_links) unless journal.notes.blank? %>
17:   </div>
18:   <%= call_hook(:view_issues_history_journal_bottom, { :journal => journal }) %>
19: <% end %>

    app/views/issues/_history.rhtml:16:in `_run_rhtml_app47views47issues47_history46rhtml_locals_history_journals_object'
    app/views/issues/_history.rhtml:2:in `each'
    app/views/issues/_history.rhtml:2:in `_run_rhtml_app47views47issues47_history46rhtml_locals_history_journals_object'
    vendor/plugins/advanced_roadmap/app/views/issues/show.rhtml:94:in `_run_rhtml_vendor47plugins47advanced_roadmap47app47views47issues47show46rhtml'
    app/controllers/issues_controller.rb:112:in `show'
    app/controllers/issues_controller.rb:111:in `show'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

It seems this is already known: http://www.redmine.org/issues/5113

#13

Updated by Emilio González Montaña almost 11 years ago

  • Target version set to Advanced roadmap 0.2.0
  • Start date deleted (2010-10-10)

I hope it will be for Christmas...

#14

Updated by Emilio González Montaña almost 11 years ago

  • Status changed from New to In progress
  • Assignee set to Emilio González Montaña
  • Start date set to 2010-12-03
#15

Updated by Emilio González Montaña almost 11 years ago

  • Subject changed from Plugin incompatible with trunk to Plugin incompatible from Redmine v1.0.0
  • % Done changed from 0 to 50
#16

Updated by Emilio González Montaña almost 11 years ago

  • Due date set to 2010-12-08
  • Status changed from In progress to Resolved
  • % Done changed from 50 to 100

A lot of changes (because Redmine v1.0.0 changes), please report me the bugs.

#17

Updated by Slava Karg almost 11 years ago

Hi!

I upgraded redmine to 1.0.4 version in order to check 0.2.0 version of plugin.

I installed plugin as usually and it appeared in section "Administration" - "Plugin" with 0.2.0 version so seemed to me that it is ok.

However when I pushed "Roadmap" for projects I noticed that Advanced_Roadmap didn't applied - original roadmap displayed :(

where could I make a mistake?

#18

Updated by Slava Karg almost 11 years ago

Hmm recently I tried again and it seems like it is installed properly now but there is one "but". Section "Total" isn't displayed. This behavior is wrong, isn't it?

Also available in: Atom PDF