Project

General

Profile

Error #636

Issues updates not showing on Redmine 1.3.0.stable.8701 (MySQL) for non administrative users

Added by Fábio Leitão over 10 years ago. Updated about 10 years ago.

Status:
Rejected
Priority:
Normal
Category:
Permissions
Target version:
-
Start date:
2012-07-09
Due date:
2012-07-09
% Done:

100%

Estimated time:
Source:
Customer
Detected on version:
Redmine version:
Redmine 1.3.0
Milestones:

Description

I have recently installed the plugin in my redmine server, very useful and beatiful... but since I am the administrator I haven't realized there was a bug for my non-administrative users.

As soon as one of them updated an issue (adding a comment or changing the status) I have recieved an email with the upgrade, and it shows to me when I browse there, but it does not show for them or for any other non-administrator user which should have access to those issues (even if they are the assignee).

I had to give it up (for now) cause they needed to follow the upgrades up, but I am willing to try and help testing possible fixes to it. I am pretty sure it has something to do with the show.xml.builder or the issues_controller_patch.rb cause the have calls for the journals information, but I am not sure what could be the root cause.


Related issues

Is duplicate of Advanced roadmap - Error #635: The Issue History isn't fully displayed unless view_issue_estimated_hours is setResolved2012-07-092012-07-09Emilio González Montaña

Actions
#1

Updated by Emilio González Montaña about 10 years ago

  • Due date set to 2012-07-09
  • Category set to Permissions
  • Status changed from New to Rejected
  • Assignee set to Emilio González Montaña
  • Start date changed from 2012-01-25 to 2012-07-09
  • % Done changed from 0 to 100
  • Source changed from Development to Customer

Also available in: Atom PDF