Project

General

Profile

Error #1341

500 Internal Server Error on some versions page access

Added by Artur H about 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Category:
Milestones
Start date:
Due date:
% Done:

0%

Estimated time:
Source:
Development
Detected on version:
Redmine version:
Redmine trunk
Milestones:

Description

When I am on the Roadmap page and have a list of all versions with all the details, click on one of versions work OK and on some other it generates 500 error as in attached log excerpt.

Started GET "/versions/135" for fe80::1c14:1be4:5ae9:ae4b at 2017-04-13 15:09:34 -0700
Processing by VersionsController#show as HTML
  Parameters: {"id"=>"135"}
  Current user: kobit (id=4)
  Rendered plugins/advanced_roadmap/app/views/versions/show.html.erb within layouts/base (4.3ms)
Completed 500 Internal Server Error in 189ms (ActiveRecord: 47.2ms)

ActionView::Template::Error (No route matches {:action=>"edit", :controller=>"wiki", :id=>#<Project id: 159, name: "Redmine Plugins", description: "A project to keep Redmine plugins developed for Ti...", homepage: "", is_public: false, parent_id: 188, created_on: "2017-02-23 10:35:43", updated_on: "2017-03-03 04:43:42", identifier: "redmine-plugins", status: 1, lft: 218, rgt: 223, inherit_members: false, default_version_id: 135, product_backlog_id: nil>, :page=>"Support_time_tracking"}):
    1: <div class="contextual">
    2:   <%= link_to_if_authorized l(:button_edit), {:controller => 'versions', :action => 'edit', :id => @version}, :class => 'icon icon-edit' %>
    3:   <%= link_to_if_authorized(l(:button_edit_associated_wikipage, :page_title => @version.wiki_page_title), {:controller => 'wiki', :action => 'edit', :id => @version.project, :page => Wiki.titleize(@version.wiki_page_title)}, :class => 'icon icon-edit') unless @version.wiki_page_title.blank? || @version.project.wiki.nil? %>
    4:   <%= call_hook(:view_versions_show_contextual, { :version => @version, :project => @project }) %>
    5: </div>
    6:
  app/helpers/application_helper.rb:48:in `link_to_if_authorized'
  plugins/advanced_roadmap/app/views/versions/show.html.erb:3:in `_plugins_advanced_roadmap_app_views_versions_show_html_erb__3856215626373335370_69883372839140'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'


Related issues

Is duplicate of Advanced roadmap - Error #1374: Internal server error 500Resolved2017-05-242017-05-24Emilio González Montaña

Actions
#1

Updated by Artur H almost 4 years ago

Tested and the problem is fixed in the last repo code. Thank you for quick resolution.

#2

Updated by Emilio González Montaña almost 4 years ago

  • Is duplicate of Error #1374: Internal server error 500 added
#3

Updated by Emilio González Montaña almost 4 years ago

  • Status changed from New to Rejected

Duplicates #1374.

Also available in: Atom PDF