Project

General

Profile

Error #326

Time log entries without related issue

Added by walcker man about 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
Reports
Target version:
Start date:
2010-12-20
Due date:
2010-12-20
% Done:

100%

Estimated time:
Source:
Detected on version:
Milestones:

Description

First Thank you for the plugin, you have done a great job.
I receive the following error with some of the users. it happens because they create an issue that is not related to a task - which sometimes is required in my project.

Processing AdvancedReportController#index (for 192.168.1.50 at 2010-09-20 14:06:11) [POST]
  Parameters: {"selected_projects"=>["2"], "period"=>"all", "from"=>"2010-08-04", "selected_members"=>["14"], "action"=>"index", "authenticity_token"=>"GEDeMIORcozhZjwAT2hEu3Fvnee5Mk8JzBcDh95fJw8=", "to"=>"2010-09-19", "period_type"=>"1", "controller"=>"advanced_report"}
retrieve_date_range()

NoMethodError (undefined method `subject' for nil:NilClass):
  vendor/plugins/advanced_report/app/controllers/advanced_report_controller.rb:97:in `index'
  vendor/plugins/advanced_report/app/controllers/advanced_report_controller.rb:97:in `sort'
  vendor/plugins/advanced_report/app/controllers/advanced_report_controller.rb:97:in `index'
  vendor/plugins/advanced_report/app/controllers/advanced_report_controller.rb:43:in `each'
  vendor/plugins/advanced_report/app/controllers/advanced_report_controller.rb:43:in `index'
  /usr/lib/ruby/1.8/mongrel/rails.rb:76:in `process'
  /usr/lib/ruby/1.8/mongrel/rails.rb:74:in `synchronize'
  /usr/lib/ruby/1.8/mongrel/rails.rb:74:in `process'
  /usr/lib/ruby/1.8/mongrel.rb:159:in `process_client'
  /usr/lib/ruby/1.8/mongrel.rb:158:in `each'
  /usr/lib/ruby/1.8/mongrel.rb:158:in `process_client'
  /usr/lib/ruby/1.8/mongrel.rb:285:in `run'
  /usr/lib/ruby/1.8/mongrel.rb:285:in `initialize'
  /usr/lib/ruby/1.8/mongrel.rb:285:in `new'
  /usr/lib/ruby/1.8/mongrel.rb:285:in `run'
  /usr/lib/ruby/1.8/mongrel.rb:268:in `initialize'
  /usr/lib/ruby/1.8/mongrel.rb:268:in `new'
  /usr/lib/ruby/1.8/mongrel.rb:268:in `run'
  /usr/lib/ruby/1.8/mongrel/configurator.rb:282:in `run'
  /usr/lib/ruby/1.8/mongrel/configurator.rb:281:in `each'
  /usr/lib/ruby/1.8/mongrel/configurator.rb:281:in `run'
  /usr/lib/ruby/1.8/mongrel/command.rb:212:in `run'

Rendering /opt/redmine/public/500.html (500 Internal Server Error)


Files

Issues.jpg (127 KB) Issues.jpg walcker man, 2010-12-12 17:19
#1

Updated by Emilio González Montaña almost 12 years ago

When you say task, do you mean version? please give me more info.

#2

Updated by Emilio González Montaña almost 12 years ago

  • Category set to Reports
  • Assignee deleted (Emilio González Montaña)
  • Target version set to 0.0.4
  • Start date deleted (2010-09-26)
#3

Updated by walcker man almost 12 years ago

This is what i mean by Task, The Issue filed is just blank not related to a task. Now the users who creates such issues causes error with the plugin

Thanks

#4

Updated by walcker man almost 12 years ago

  • File Issues.jpg added

Here it is

#5

Updated by Emilio González Montaña almost 12 years ago

  • File deleted (Issues.jpg)
#6

Updated by Emilio González Montaña almost 12 years ago

  • Tracker changed from Feature to Error
  • Subject changed from Error with the plugin to Time log entries without related issue

The terms are completely incorrect, the problem is mqking a time log entry without related issue... I'll check it for the next release.

#7

Updated by Emilio González Montaña almost 12 years ago

  • Status changed from New to In progress
  • Assignee set to Emilio González Montaña
  • Start date set to 2010-12-20
#8

Updated by Emilio González Montaña almost 12 years ago

  • Due date set to 2010-12-20
  • Status changed from In progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF