Project

General

Profile

Defect #1569

Internal Server Error on scrum_tips

Added by Quan Nguyen 5 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Category:
General
Source:
Development
Detected on version:
Blocked:
No
Alone:
Yes
Milestones:
Sprint:

Description

Hi,

I cannot start redmine with your plugin.

Redmine info:

Environment:
  Redmine version                4.0.0.stable
  Ruby version                   2.5.3-p105 (2018-10-18) [x86_64-linux]
  Rails version                  5.2.2
  Environment                    production
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                smtp
SCM:
  Git                            1.8.3.1

Log as below:

Completed 500 Internal Server Error in 39ms (ActiveRecord: 12.1ms)

ActionView::Template::Error (uninitialized constant Scrum::Setting
Did you mean?  Setting
               String):
    1: <%- tips = scrum_tips -%>
    2: <%- unless tips.empty? -%>
    3:   <h3><%= l(:label_tip_title) %> <%= image_tag("help.png") %></h3>
    4:   <ul>

plugins/scrum/lib/scrum/application_helper_patch.rb:99:in `scrum_tips'
plugins/scrum/app/views/scrum_hooks/_scrum_tips.html.erb:1:in `_plugins_scrum_app_views_scrum_hooks__scrum_tips_html_erb___2516469347768283280_73904820'
lib/redmine/hook/view_listener.rb:59:in `block (2 levels) in render_on'
lib/redmine/hook/view_listener.rb:57:in `map'
lib/redmine/hook/view_listener.rb:57:in `block in render_on'
lib/redmine/hook.rb:61:in `block (2 levels) in call_hook'
lib/redmine/hook.rb:61:in `each'
lib/redmine/hook.rb:61:in `block in call_hook'
lib/redmine/hook.rb:58:in `tap'
lib/redmine/hook.rb:58:in `call_hook'
lib/redmine/hook.rb:96:in `call_hook'
app/helpers/application_helper.rb:1459:in `view_layouts_base_sidebar_hook_response'
app/helpers/application_helper.rb:1455:in `sidebar_content?'
app/views/layouts/base.html.erb:99:in `_app_views_layouts_base_html_erb___3685052083580796633_61097320'
lib/redmine/sudo_mode.rb:63:in `sudo_mode'
#1

Updated by Emilio González Montaña 5 months ago

Hi, when you say:

I cannot start redmine with your plugin.

Do you really mean running rails server? I mean start redmine, because the log seems to be a page rendering not redmine start log.

If I’m right, did you restart your redmine instance (+ plugins db migration) after updating the scrum plugin? I guess yes, but it’s to be 100% sure.

#2

Updated by Quan Nguyen 5 months ago

Emilio González Montaña escribió:

Hi, when you say:

I cannot start redmine with your plugin.

Do you really mean running rails server? I mean start redmine, because the log seems to be a page rendering not redmine start log.

If I’m right, did you restart your redmine instance (+ plugins db migration) after updating the scrum plugin? I guess yes, but it’s to be 100% sure.

I install your plugin (first time I use this one), after that I restart redmine. But when I open my page, I got error 500 Internal Server Error. I get error log of production which I mention in this issue.

#3

Updated by Emilio González Montaña 5 months ago

And did you run plugins db migrate?

#5

Updated by Quan Nguyen 5 months ago

Emilio González Montaña wrote:

https://redmine.ociotec.com/projects/redmine-plugin-scrum/wiki#Installation

I already install plugin db migrate

Emilio González Montaña wrote:

https://redmine.ociotec.com/projects/redmine-plugin-scrum/wiki#Installation

I already step by step installing as below:
  • Put your plugin in <redmined>/plugins folders (remove version of plugin, Name is only "scrum")
  • Run command for migrating (RAILS_ENV=production bundle exec rake redmine:plugins:migrate)
  • Restart redmine
#6

Updated by Emilio González Montaña 3 months ago

  • Alone changed from No to Yes
  • Sprint set to Sprint 38
  • Description updated (diff)
  • Subject changed from Internal Server Error to Internal Server Error on scrum_tips
#7

Updated by Emilio González Montaña 3 months ago

  • Target version deleted (Scrum 0.20.0)
  • Status changed from New to Rejected

Quan Nguyen wrote:

Emilio González Montaña wrote:

https://redmine.ociotec.com/projects/redmine-plugin-scrum/wiki#Installation

I already install plugin db migrate

Emilio González Montaña wrote:

https://redmine.ociotec.com/projects/redmine-plugin-scrum/wiki#Installation

I already step by step installing as below:
  • Put your plugin in <redmined>/plugins folders (remove version of plugin, Name is only "scrum")
  • Run command for migrating (RAILS_ENV=production bundle exec rake redmine:plugins:migrate)
  • Restart redmine

No way to reproduce it, I rejected unless I get more info to reproduce it. Quan, is still happening? Did you tried with Redmine 4.1 series?

I've tested again on 4.1 but no error message... all the steps you have commented are OK, but the error is similar to other errors when the plugin folder is not scrum... maybe it's an issue of Redmine 4.0.0 with the scrum plugin, please consider to test it with 4.1 and latest master scrum plugin (only available for Patreon supporters https://www.patreon.com/ociotec).

Also available in: Atom PDF